Bigbruin.com
Home :: Reviews & Articles ::
Forum :: Info :: :: Facebook :: Twitter :: Youtube :: RSS Feed
Search  :: Register :: Log in
Reduce Sapphire Toxic Radeon HD4870 Fan Noise
http://www.bigbruin.com/2008/toxicbios_1
Go To Page Previous  1, 2, 3, 4, 5  Next
Post new topic   Reply to topic    Bigbruin.com Forum Index -> Articles
View previous topic :: View next topic  
Author Message
ayeaye
Rated PG


Joined: 07 Feb 2009
Posts: 2

PostPosted: Sat, 07 Feb 2009 07:47:26    Post Subject: Reply with quote View Single Post

Hi, came across this site looking for info on the fan noise on the Toxic 4870 - appreciate it if you could send me the info on how to obtain the BIOS to silence the fan!

Cheers
Back to top
View user's profile Send private message
Little Bruin
Boo Boo

Joined: 07 Apr 2003
Posts: 667
Location: Pic-A-Nic Basket
Doctor Feelgood
Arrrrghh!


Joined: 07 Apr 2003
Posts: 20254
Location: New Jersey

PostPosted: Sat, 07 Feb 2009 14:32:41    Post Subject: Reply with quote View Single Post

ayeaye - I sent you an e-mail!

Could anyone who tried it provide their feed back?

Also... If anyone has a Sapphire HD4850 X2 that wants to reduce the noise... I may have a link to something for that, too.
Back to top
View user's profile Send private message Visit poster's website
ayeaye
Rated PG


Joined: 07 Feb 2009
Posts: 2

PostPosted: Sat, 07 Feb 2009 17:46:31    Post Subject: Reply with quote View Single Post

Thanks Jason.

Applied the BIOS update.

With the original BIOS, after starting GTA IV the fan would roar into life and be very distracting. With the new BIOS can barely hear it. Temps are maybe 8 - 9 degrees (celcius) higher than before, but I'm happy with that trade off to have a quite graphics card once again!

The only thing that's slightly odd is that in the catalyst control centre, the BIOS version and BIOS part number are identical pre- and post-upgrade, the only change is that the BIOS date went from 9th September 2008 to 25th September 2008. Does this mean Sapphire were aware of the issue as far back as Sep 2008 and are shipping newer cards with the updated BIOS?


Cheers
Paul
Back to top
View user's profile Send private message
Doctor Feelgood
Arrrrghh!


Joined: 07 Apr 2003
Posts: 20254
Location: New Jersey

PostPosted: Sat, 07 Feb 2009 21:55:58    Post Subject: Reply with quote View Single Post

Hmmm... Sounds like a release tracking issue... Shouldn't be a different product with the same number. Maybe what I got was a prototype that didn't have an official number yet...
Back to top
View user's profile Send private message Visit poster's website
GlitchGR
Rated PG


Joined: 10 Feb 2009
Posts: 1

PostPosted: Tue, 10 Feb 2009 10:28:10    Post Subject: Reply with quote View Single Post

Hi jason,

Would you mind sending me links to the updates for the 4870. I want to try that before i brake down and swap out the noise box of a fan for something a bit quieter.

thanks
Back to top
View user's profile Send private message
Doctor Feelgood
Arrrrghh!


Joined: 07 Apr 2003
Posts: 20254
Location: New Jersey

PostPosted: Tue, 10 Feb 2009 12:21:49    Post Subject: Reply with quote View Single Post

Check your e-mail!

This should do the trick... I was very impressed with the results. Even after flashing the 4850X2 with its quiet BIOS it wasn't as quiet as the 4870 Toxic, so I actually use the 4870 Toxic in my main system... So, the 4850X2 sits on a shelf with the 4870X2 which is just not being used due to the integrated CPU cooler... Bang Head
Back to top
View user's profile Send private message Visit poster's website
loutsos
Rated PG


Joined: 13 Feb 2009
Posts: 2

PostPosted: Fri, 13 Feb 2009 13:21:44    Post Subject: Reply with quote View Single Post

Does anyone have the bios file?
Back to top
View user's profile Send private message
Little Bruin
Boo Boo

Joined: 07 Apr 2003
Posts: 667
Location: Pic-A-Nic Basket
Doctor Feelgood
Arrrrghh!


Joined: 07 Apr 2003
Posts: 20254
Location: New Jersey

PostPosted: Fri, 13 Feb 2009 14:08:40    Post Subject: Reply with quote View Single Post

You do! Check your inbox... Grin
Back to top
View user's profile Send private message Visit poster's website
loutsos
Rated PG


Joined: 13 Feb 2009
Posts: 2

PostPosted: Fri, 13 Feb 2009 18:34:25    Post Subject: Reply with quote View Single Post

Guys I need your help...

I'm using an ATI Sapphire 4870 512 MB Toxic and a Samsung SyncMaster T220HD. I'm running Windows Vista Ultimate in 1680x1050.

The problem is sometimes when I'm palying games or even using programs such as MSN or Firefox(only in fullscreen or maximized mode) the monitor dies!(Black screen and "No Signal" message)

I've flashed my card with latest bios, changed clocks, installed latest drivers but all I get is problems...

I'm desperate... Any ideas?
Back to top
View user's profile Send private message
~*77*~
Xenophobe


Joined: 08 Apr 2003
Posts: 10466
Location: Sshh... I'm Hiding

PostPosted: Sat, 14 Feb 2009 13:02:26    Post Subject: Reply with quote View Single Post

Was it doing this before the BIOS flash or did it just start afterward?

What drivers are you using? Maybe check for the latest... 9.1
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Bigbruin.com Forum Index -> Articles All times are GMT - 4 Hours
Go To Page Previous  1, 2, 3, 4, 5  Next
Page 2 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Contact Us :: On Facebook :: On Twitter :: On Youtube :: Newsletter :: RSS Feed :: FAQ :: Links :: Sponsors :: Privacy Policy
Copyright © 2000 - 2018 Bigbruin.com - All rights reserved